Erfahrungsbericht: Ultraschall Durchflussmesser TUF-2000M


Nachdem meine Heizung, eine Wasser-Wasser-Wärmepumpe keine Möglichkeit bietet den Wasserdurchfluss des primären Wasser-Kreislaufs zu messen oder aufzuzeichnen, konnte ich nicht abschätzen, ob genügend Wasser aus dem Entnahmebrunnen gefördert wird. Neben der Notwendigkeit für die Genehmigung der Anlage über die Fördermenge Schrift führen zu müssen, ist das Wissen über den Wasserdurchfluss für diese Art von Anlage essentiell für eine eventuelle Fehlerdiagnose. Um den Primärkreis als potentielle Fehlerquelle besser im Auge behalten zu können, habe ich mich nach einer Möglichkeit für die Messung des Durchflusses umgesehen. Nach einer kurzen Recherche, bin ich bei Ultraschall-Durchflussmessern gelandet. Das Prinzip klingt erst einmal genial: Zwei kleine Ultraschall-Sensoren messen den Wasserdurchfluss von außen über die Laufzeit des Schalls. Für die Installation muss der Wasserkreislauf nicht unterbrochen werden und die Tatsache, dass die Messung den Durchfluss keinesfalls beeinflusst, ist ein wesentlicher Vorteil dieser Technik. Einziger Nachteil, die Geräte sind relativ teuer. Immer noch nicht ganz günstig, aber leistbar, bin ich bei dem Gerät TUF-2000M TDS-100 gelandet. Über eine serielle Schnittstelle kann das Gerät ausgelesen und der Wasserdurchfluss aufgezeichnet werden, dazu mehr in einem gesonderten Artikel.

Der TUF-2000M kann ab ca. 200€ bis ca. 400€ erworben werden, exklusive Netzteil.

 Zusätzlich zum Bild wurde der TUF-2000M mit 2 TS-2 Ultraschallsensoren geliefert.

Stromversorgung

Das Netzteil ist nicht Teil des Lieferumfangs, daher habe ich ein normales 12V-Gleichstrom-Netzteil verwendet. Das Netzteil stammt aus meiner Wühlkiste mit alten Ladegeräten. Ich glaube es hat ursprünglich Philips-LED-Kerzen geladen, bevor diesen eines Tages das Licht ausgegangen ist. Nach jahrelanger Arbeitslosigkeit, hat das Netzteil jetzt wieder eine Festanstellung, als Stromversorgung für den Wasserdurchflussmesser: 

Anschlussschema 

Die Anschlüsse am Flowmeter sind gut beschriftet, entsprechend selbsterklärend ist die Verkabelung:

Das mitgelieferte Kabel ist gefühlt 10 Meter lang, 2polig und mit Schirmung:

Zum Testen habe ich anfangs kurze 3-adrige 1,5mm² Elektro-Kabel und Kabelbinder verwendet um bei einem Scheitern des Projektes alle Teile des Lieferumfangs möglichst intakt zurücksenden zu können. Ein kurzes Resümee: Die Elektrokabel hätten auch funktioniert und das Zurücksenden war nicht notwendig, entsprechend habe ich die Sensoren fixiert:

 

Wichtig: Damit die Ultraschallsensoren funktionieren, muss auf der Unterseite etwas Fett aufgetragen werden, ich habe dazu Vaseline verwendet. Vor der endgültigen Montage sollten die Parameter im Gerät eingestellt werden, da der Menüpunkt M25 den Abstand der Sensoren am Rohr vorgibt, siehe M24 / M25.

Einrichtung

Display-Anzeigen

Ich habe meine aktuellen Einstellungen mit der Pfeil-nach-Rechts-Taste einmal durchgeklickt und hier dokumentiert. Die Menüpunkte können auch direkt über die Taste "MENU" und durch Eingabe der Nummer ausgewählt werden. Für das Einrichten des Flowmeter kann dabei direkt mit Menüpunkt M11 gestartet werden.

Übersicht Menü 00-09

Die Menüpunkte 00-09 zeigen, ein korrektes Setup vorausgesetzt, Werte zum Durchfluss, der Energie und Temperatur-Werte:

   

Die Temperatur-Anzeige der TS-2 Transducer zeigt bei mir ca. 40°C bei einem Widerstand von 115Ohm, die Temperatur des Rohres ist dabei ca. 11°C. Der Umrechungsfaktor 115Ohm auf 40°C würde in die Kurve eines PT100-Temperatursensors passen: Ich würde daraus schlussfolgern, dass bei meinen TS-2 Transducer kein normaler PT100-Sensor verbaut ist. Wichtiger als die Temperatur ist die Schallgeschwindigkeit der Flüssigkeit (Fluid-Sound Velocity) welche für meine ca. 11°C Wassertemperatur vom Gerät mit ca. 1435 m/s angezeigt wird: was für reines Wasser plausibel ist ... (siehe: Menüpunkt 92). Soweit für mich ok, immerhin habe ich das Gerät nicht zum Messen der Temperatur besorgt, bzw. wäre es möglich zusätzliche Temperatursensoren anzubinden, die Werte dafür erscheinen im nächsten Menüpunkt, mit der Nummer 07:

Nachdem ich auf den Kontakten AI3 und AI4 nichts angeschlossen habe, sind diese Werte nahe bei 0.

Interessant ist auch der Status in Menü 08: Erst nachdem ich auf die Flow-Sensoren etwas Vaseline aufgetragen habe, konnten dieser etwas auslesen und der Status ist auf "System Normal" gewechselt:

 

Zwischen M10 und M11 kommt dann noch folgende Anzeige, ich schätze an dieser Stelle könnten Meldungen über eine Schnittstelle an den FlowMeter übertragen werden?

Rohr-Einstellungen Menü 10-16

Ursprünglich wurde im Menü 10 der "Outer Perimeter" angezeigt, aktuell hüpft das Menü gleich direkt zu Pipe Outer Diameter: M11, womit auch die relevanten Einstellungen für die Durchflussmessung starten. Relevant für die Messung sind die Menüpunkte M11 (Pipe Outer Diameter), M12 (Pipe Wall Thickness) und M14 (Pipe Material) in meinem Fall handelt es sich um eine Kupferleitung. Der Menüpunkt M13 wird automatisch aus M11 und M12 berechnet.

     

Sensor-Einstellungen Menü 20-xx

Im Menüpunkt 20 kann die Art der Flüssigkeit angegeben werden, in meinem Fall Wasser und mit M23 muss der verwendete Ultraschallsensor eingestellt werden:

Transducer Mounting ist die Variante, wie die Sensoren am Rohr montiert werden. V ist dabei die präferierte Variante für Rohre zwischen 15 und 200mm. Die Sensoren werden dabei auf der selben Rohrseite im Abstand des nächsten Menüpunktes M25 "Transducer Spacing" montiert:

Anders als ich anfangs angenommen habe, ist der Abstand der Sensoren vom Rohrdurchmesser und der Montage-Variante abhängig und vorgegeben: Die Sensoren müssen entsprechend des Wertes montiert werden.

Einstellungen speichern

Menü 26 ermöglicht die aktuellen Einstellungen zu speichern, damit diese nach einem Stromausfall oder Neustart des Flowmeter wieder verwendet werden. M27 ermöglicht das Speichern und Laden verschiedener Einstellungen.

 

M28- ...

Kein Durchfluss kalibrieren

Sollte im Rohr gerade kein Wasserfluss stattfinden, aber dennoch ein Fluss angezeigt werden, kann der Durchflussmesser mit Menüpunkt 42 kalibriert werden:

"M42: Set Zero" sollte also nur ausgeführt werden, wenn sich die Flüssigkeit im Rohr nicht bewegt. Der Durchflussmesser zählt dabei einige Sekunden herunter und sollte im Anschluss Werte nahe 0 anzeigen.

M44 - ...

Der Menüpunkt M49 zeigt bei mir Daten am Serial-Port, dies liegt daran, dass ich einen ESP32 an die RS485 angeschlossen habe um die Daten über WiFi an HomeAssistant zu übertragen, siehe: ESP32 Flowmeter - RS485 Modbus

M50 - ...

 

M62 und M63 RS-485

Für die Kommunikation mit dem ESP32 habe ich M62 (RS-485/RS-232) auf "9600,None,8,1" gestellt und M62 (Select Comm Protocol) auf "MODBUS RTU Only":

M64 - ...

M92:

Genauigkeit

Abhängig vom Abstand der Ultraschallsensoren, zeigt dieser eine andere Durchflussmenge: Bei einem geringeren Abstand als dem angegebenen Wert würde mehr Durchfluss angezeigt werden. Beim errechneten Abstand hab ich in Menü 91 ca. 103%, was gerade noch in der Toleranz von 100 +- 3% liegt. Würde ich den Abstand verringern, würde Menü 91 näher Richtung 100% gehen, die Fluid Sound Velocity würde dann steigen und mehr Durchfluss angezeigt werden. Die Genauigkeit hängt sicherlich von der Installation ab: ob das Rohr lange genug ist, die Parameter für den Rohrdurchmesser stimmen, was dann im Menü 91 zu einem Wert in der der Nähe von 100% führen sollte. Zudem ist eine Signalqualität von über 85% notwendig um stabile Werte zu erhalten.

Fazit

Nachdem ich auf die Sensoren etwas Vaseline aufgetragen habe, hat der Durchflussmesser relativ schnell begonnen seine Arbeit zu verrichten. Leider habe ich keine wirkliche Referenz für die Durchflussmenge, womit es mir nicht möglich ist die Genauigkeit des Durchflussmessers zu validieren. Die angezeigten Werte bewegen sich aber absolut im Bereich des möglichen. Für das Sammeln der Daten über RS485 und einen ESP32, siehe: ESP32 Flowmeter - RS485 Modbus.

positive Bewertung({{pro_count}})
Beitrag bewerten:
{{percentage}} % positiv
negative Bewertung({{con_count}})

DANKE für deine Bewertung!


Top-Artikel in diesem Bereich

Preview Fehlersuche Schleifensignal Suchschleife Husqvarna Automower

Fehlersuche Schleifensignal Suchschleife Husqvarna Automower

geändert: 19.08.2021 von Bernhard (Erstveröffentlichung: 25.10.2019)

Was, wenn eines Tages die Suchschleife des Mähroboters unterbrochen ist. Wer gerade im Garten herum gegraben hat, dem fällt das Suchen nach der Problemstelle relativ leicht, anders wenn der Mäher ohne offensichtliche Fremdeinwirkung kein Schleifensignal mehr hat. Die LED auf der Ladestation leuchtet dann nicht mehr grün, sondern blinkt in der Farbe Blau oder bei den Modellen 305/308 in Gelb. Genau dieses Schicksal hat mich schon mehrmals ereilt. Ich habe vor längerer Zei... ... weiterlesen

Preview Conbee 2: Phoscon deCONZ - Docker Inbetriebnahme | Review

Conbee 2: Phoscon deCONZ - Docker Inbetriebnahme | Review

geändert: 31.07.2021 von Bernhard (Erstveröffentlichung: 20.08.2020)

Mit dem kleinen USB-Stick Conbee2 habe ich meinen NAS um ein Zigbee-Gateway erweitert. Conbee2 kann auf Raspbian, Ubuntu, Docker oder Windows installiert werden. ... weiterlesen

Preview Steuern des Automowers mittels Steckdose - Regensensor?

Steuern des Automowers mittels Steckdose - Regensensor?

geändert: 28.09.2018 von Bernhard (Erstveröffentlichung: 07.05.2016)

In puncto Automatisierung bietet der Husqvarna Automower leider sehr wenig Möglichkeiten und so gut wie keine Dokumentation. Es gibt dennoch inoffizielle Wege, den Mäher zu steuern. Zum einen kann das Automower Connect-Modul, eine Internet-SIM-Karte und eine inoffizielle API für die Steuerung verwendet werden, zum anderen kann der Mäher durch gezieltes Ausschalten der Ladestation gesteuert werden, mehr dazu in diesem Artikel. ... weiterlesen


Fragen / Kommentare


Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu Mehr Details